We are THE friendliest motorhome forum, please register to join in the fun, and have access to all areas.


Introduce yourself

Sign up Latest Topics Donate
 
 
 


Reply
  Author   Comment  
Gerty

Avatar / Picture

Executive member
Registered:
Posts: 4,775
Reply with quote  #1 
Advice needed please.
Just moved the van and when I started it--- in big letters it said OIL PRESSURE TURN OFF ENGINE, but within seconds the sign had gone. I have checked the oil, lovely and clean and up to the mark so could this be a false alarm?

__________________
I answer to Gerty, Jan or Milly

We learn something new every day.


I drive a Navajo.


0
Pudsey Bear

Avatar / Picture

Really should get out more
Registered:
Posts: 12,402
Reply with quote  #2 
Try it again tomorrow gert, it could be a pump problem, or just a glitch in the puter.
__________________
Kev [comp] 

Warning, might contain an opinion [nono]  

If you're not the lead dog, your view never changes.

Don't force it, use a bigger hammer. Semper ubi, Sub ubi. 

Link to self build pictures

Link to sort of blog on facts


http://tinyurl.com/nzyry9n

2002 Bessacarr E745 Ducato
0
coppo

Avatar / Picture

Executive member
Registered:
Posts: 2,685
Reply with quote  #3 
Has it been stood a long time?
0
SANDBAGSID

Avatar / Picture

Senior Executive member
Registered:
Posts: 6,757
Reply with quote  #4 
If you haven’t started it for a while the oil might have drained back into the sump but I wouldn’t have thought it’s been standing that long really. See what it says later today jan as kev said could be ya oil pump but as the engine is new I would think they would have fitted a new pump. Could well be just a sticky sensor van needs a good thrashing 😎🏁
__________________

Alan    Ford transit pvc.

Bracknell forest Berkshire. 

0
Gerty

Avatar / Picture

Executive member
Registered:
Posts: 4,775
Reply with quote  #5 
No, I take it for a spin now and then, last time was on the 9th of this month. I was going out this afternoon, but another problem sprung up, the hose connection on the water tank broke just as I was coming to the end of the weed killing on the drive. 
__________________
I answer to Gerty, Jan or Milly

We learn something new every day.


I drive a Navajo.


0
BurtSner

Avatar / Picture

Administrator. Executive member, Forum supporter.
Registered:
Posts: 6,178
Reply with quote  #6 
First of all don’t worry. Second, try it again tomorrow - if it lights again have a worry. I reckon it won’t and it’s just a temporary switch glitch. 
__________________
Burstner Nexxo T660 - family fun
1974 Norton Commando
1999 Suzuki Hayabusa
Molly - Chocolate Labrador 
only a biker understands why a dog hangs its head out of the window
Exeter, East Devon

Simon
0
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.

Go to top of page         Return to forum home page