We are THE friendliest motorhome forum, please register to join in the fun, and have access to all areas.


Introduce yourself

Sign up Latest Topics Donate
 
 
 


Reply
  Author   Comment  
powerplus

Avatar / Picture

Moderator extraordinaire
Registered:
Posts: 898
Reply with quote  #1 
hi all

im just trying to get some help for someone on site

he has  a 2003 Ducato with a alco chassis it seems the compressor is not working 

his van automatically pumps up when the ignition is turned on as there are no gauges only a red light


i have struggled to get underneath  and found what i think is a compressor inside a steel box


i cannot find any pictures on yahoo that look the same  and i cannot get inside the box as it is just to hard to get to

does this ring a bell with any older Ducato owners


i will try and look at the airbags to try and find out if they are possibly Dunlop or something else


any help would be appreciated 

barry


0
SANDBAGSID

Avatar / Picture

Senior Executive member
Registered:
Posts: 7,072
Reply with quote  #2 
My citron dispatch has a compressor in a oblong metal box inside it has four flow and return valves two for each side one pumps the bag up the other lets it down, was quoted £800 for a new one but got a second hand one from a scrapyard £235 was a bit of luck.
__________________

Alan    Ford transit pvc.

Bracknell forest Berkshire. 

0
powerplus

Avatar / Picture

Moderator extraordinaire
Registered:
Posts: 898
Reply with quote  #3 
hi alan

thanks 

i am looking further to see if i can find out the make

barry
0
powerplus

Avatar / Picture

Moderator extraordinaire
Registered:
Posts: 898
Reply with quote  #4 
hi all

it appears its a dunlop system with a fancy control that lets you rais and lower the van with a rocker switch 

 so thats a start but no real details on the system 

maybe tomorrow i may make a couple of phone calls



barry


0
Griff097

Junior Member
Registered:
Posts: 14
Reply with quote  #5 

Not sure it's relevant to this discussion, but I have 3 shrader valves on the side of the body, near the rear axle, not having had a MH before I am not sure what they are for.

Is it some sore of air assistance for the leaf springs maybe, if so what sort of pressure should be inb the system, assuming it's adjustable.

0
Pudsey Bear

Avatar / Picture

Really should get out more
Registered:
Posts: 12,787
Reply with quote  #6 
If it is air suspension there will be bags on top of the axle at each side, pressure would normally be 1 bar maybe a little more according to how it rides, odd place to put the valves though, they are normally in the cab near the seats, and I can't think what the third one might be for.
__________________
Kev [comp] 

Warning, might contain an opinion [nono]  

If you're not the lead dog, your view never changes.

Don't force it, use a bigger hammer. Semper ubi, Sub ubi. 

Link to self build pictures

Link to sort of blog on facts


http://tinyurl.com/nzyry9n

2007 Citroen Relay XLWB self build
0
tugboat

Avatar / Picture

Outstanding in their field, Forum Supporter.
Registered:
Posts: 2,073
Reply with quote  #7 
Suivez le pipework, methinks.[confused]
__________________
The sign on my cabin door said 'Not enough bucks stop here'

Geoff.
Bessacarr E725, Honda Vision, Piaggio BV350.
South Devon.
0
ray

Avatar / Picture

Senior Member
Registered:
Posts: 446
Reply with quote  #8 
My air pump was under the drivers seat if that is any help?.

ray.
0
BurtSner

Avatar / Picture

Administrator. Executive member, Forum supporter.
Registered:
Posts: 6,445
Reply with quote  #9 
Did you manage to find a fix, Barry?
__________________
Burstner Nexxo T660 - family fun
1974 Norton Commando
1999 Suzuki Hayabusa
Molly - Chocolate Labrador 
only a biker understands why a dog hangs its head out of the window
Exeter, East Devon

Simon
0
powerplus

Avatar / Picture

Moderator extraordinaire
Registered:
Posts: 898
Reply with quote  #10 
hi simon


yes all sorted basically it in a bit of a state but when i looked at it properly i found that the guy had the mains lead still plugged in so even with the engine running the pump did not get a 12v supply

i removed the mains lead and vala pump started

the guy has had the van for 10 years and its 1 problem after the other for him but they are of his own doing 

i should realize by now that people are getting older and some are beginning to get the dementia thing his sister is allready has it and she and her husband (deceased) were the ones here in portugal that i ended up putting in a Portuguese care home home

the trouble is they dont realize they are getting that way

he says that if he gets like his sister he will get himself into a care home



i think i must be a mug as all the old guys that are 19,6d come and get me

barry
0
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.

Go to top of page         Return to forum home page